Breeze Emails are not loading
Incident Report for BreezeChMS
Resolved
This incident has been resolved.
Posted Jan 09, 2024 - 15:21 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 09, 2024 - 15:20 PST
Investigating
We are currently investigating the issue
Posted Jan 09, 2024 - 14:59 PST
This incident affected: Site.