Pages loading slowly in Breeze Giving & People
Incident Report for BreezeChMS
Resolved
This incident has been resolved, but our team will continue to monitor Breeze pages throughout the week
Posted Jan 22, 2024 - 14:38 PST
Identified
The issue has been identified and a fix is being implemented.
Posted Jan 22, 2024 - 08:42 PST
Update
We are continuing to investigate this issue.
Posted Jan 22, 2024 - 08:17 PST
Investigating
We're currently investigating slowdowns related to loading Breeze contribution and people pages
Posted Jan 22, 2024 - 08:17 PST
This incident affected: Site.