Issues with emails not being delivered

Incident Report for BreezeChMS

Resolved

This issue has been fully resolved for our teams and we are seeing these emails send through as expected.
Posted Jul 17, 2025 - 14:39 PDT

Update

Our Engineering team is preparing to deploy a fix for this issue.
Posted Jul 17, 2025 - 14:24 PDT

Identified

Our teams have identified the source of the issue and are working to resolve
Posted Jul 17, 2025 - 14:08 PDT

Investigating

Our teams are investigating reports of emails not sending through as expected. Initial indications are system generated emails are the most affected. We'll provide additional updates soon
Posted Jul 17, 2025 - 13:46 PDT
This incident affected: Site and Email Service.