Issues viewing Breeze email history

Incident Report for BreezeChMS

Update

Our emails are sending and functional at normal levels once more. While we are continuing to monitor the stability of Breeze pages today, our team is aware of the Email History only showing the last 30 days of sends. We are working to bring those back into your views.
Posted Apr 25, 2025 - 19:52 PDT

Update

While we are continuing to monitor the stability of Breeze pages today, our team is aware that some Breeze emails have been delivering multiple times over the past 24 hours. While we are monitoring the resolution, it is likely that today's sent or scheduled emails could be potentially delayed to send.
Posted Apr 25, 2025 - 07:11 PDT

Monitoring

We have identified the root cause and have found Breeze pages are loading as expected again. We will continue to monitor the results throughout the day.

We are also continuing to closely monitor incidents where emails have sent multiple times.
Posted Apr 25, 2025 - 05:32 PDT

Investigating

We are currently investigating an issue that is affecting loading Breeze pages. We will be sharing additional updates here as available.
Posted Apr 25, 2025 - 05:17 PDT
This incident affects: Site, Database, Email Service, Online Giving (Transaction Processing), Worship Tools (Song Select, Worship App), and SMS / Texting (Texting Service, Shortcode Texting).