Issues with Breeze Check In App

Incident Report for BreezeChMS

Resolved

We’re back! Breeze Check In should be up and running. Thanks for bearing with us.
Posted Jul 11, 2026 - 21:29 PDT

Identified

We’ve identified the issue causing the problem and are working to fix this as quickly as we can. We’ll share another update shortly.
Posted Jul 11, 2026 - 20:08 PDT

Investigating

Our team is investigating an issue affecting the Breeze Check In app where it is not showing Brother Printers as expected. We are handling this as a very urgent issue, and will be making every effort to have this resolved before Sunday Services.

Our current encouragement is to disable automatic app updates in the App Store settings. We'll share updates here as we have them.
Posted Jul 11, 2026 - 18:29 PDT
This incident affected: Site.