Issues accessing Breeze Accounts

Incident Report for BreezeChMS

Resolved

This issue has been resolved and access restored to affected customers.
Posted Apr 29, 2026 - 12:07 PDT

Identified

Our team has identified the source of the issue and is working on the fix currently.
Posted Apr 29, 2026 - 10:47 PDT

Investigating

We are aware of an issue where some customers are experiencing errors when attempting to access their Breeze account. Our Engineering team is investigating and will we provide an update here soon.
Posted Apr 29, 2026 - 09:32 PDT
This incident affected: Site and Database.