Investigating Degraded Performance for Breeze
Incident Report for BreezeChMS
Resolved
The pages that were not loading within Breeze should be up and running. Thank you for your patience!
Posted Nov 13, 2023 - 10:34 PST
Identified
We’ve identified a current root cause and are working quickly as we can. We’ll share another update shortly.
Posted Nov 13, 2023 - 09:08 PST
Investigating
We are investigating issues loading specific pages within Breeze.
Posted Nov 13, 2023 - 07:54 PST
This incident affected: Site.