Issues exporting from People

Incident Report for BreezeChMS

Resolved

Our Engineering teams have resolved the issues affecting exporting and things are working as expected!
Posted Sep 25, 2025 - 09:53 PDT

Investigating

Our teams are aware of an issue affecting the exporting from People. We will provide updates shortly.
Posted Sep 25, 2025 - 08:47 PDT
This incident affected: Site and Database.