Issues loading pages within Breeze
Incident Report for BreezeChMS
Resolved
This is resolved and pages are loading as expected now. Our Engineers are working diligently to improve loading speeds on days with a higher than normal usage.
Posted Nov 27, 2023 - 12:27 PST
Identified
Our Engineering teams are aware of the trouble and are working to get this fully resolved. We should see speeds return to normal in less than one hour.
Posted Nov 27, 2023 - 10:44 PST
Investigating
We are investigating an issue with certain pages loading within Breeze (namely Funds / Pledges)
Posted Nov 27, 2023 - 10:05 PST
This incident affected: Site and Database.