We’re back! Both Breeze admin apps should be up and running for both IOS and Android. Thanks for bearing with us.
Posted Aug 25, 2025 - 06:46 PDT
Update
We have released a new version of the Breeze Admin App in both the Apple App and Google Play stores which resolves this issue for both iOS and Android users. If you are experiencing this please visit the App Store and check for an update. If you are not able to do the update, deleting the app and reinstalling it should also give you the latest version.
We will continue to keep this incident updated as we verify full resolution for all users.
Posted Aug 23, 2025 - 04:32 PDT
Monitoring
A full resolution is still underway. This issue originated with an upstream provider and while we are currently awaiting approval from the Google Play Store, we are back up and running in the Apple App store. You may experience slightly difference experiences in this version of the app compared to the previous version. We’re monitoring for these differences. We’ll share another update shortly.
Posted Aug 21, 2025 - 11:21 PDT
Update
We've confirmed there is an issue with an upstream provider that is causing issues in the Breeze Admin App. We encourage you to use Breeze directly from your device's browser as we continue work to fully resolve this issue.
Posted Aug 20, 2025 - 17:24 PDT
Investigating
Our teams are aware of an issue affecting the loading of the Breeze Admin App. This appears to be an issue with an upstream provider, however we are working to ensure this is resolved as quickly as possible.