Extended Maintenance Period

Incident Report for BreezeChMS

Resolved

This incident has been resolved.
Posted Mar 28, 2025 - 04:03 PDT

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 27, 2025 - 22:04 PDT

Investigating

We are currently investigating an issue that has caused us to prolong our maintenance period.
Posted Mar 27, 2025 - 21:28 PDT
This incident affected: Site, Database, Email Service, Online Giving (Transaction Processing), Worship Tools (Song Select, Worship App), and SMS / Texting (Texting Service, Shortcode Texting).