Online Giving showing incorrect stripe_fee

Incident Report for BreezeChMS

Resolved

We've confirmed that the charges are not continuing and are working with our partner to ensure that all are being refunded automatically. We're marking this as resolved and will work directly with any affected customers to ensure this is handled.
Posted Sep 03, 2025 - 17:33 PDT

Identified

We're aware that some of our customers using Breeze Giving are seeing a recent "stripe_fee" on their transaction reports. This is an incorrect fee being assessed and we're working with our Giving Processor (Stripe) to ensure this is resolved, and these fees refunded as quickly as possible. Those experiencing this will NOT need to contact our team for verification as we're able to see impact and resolve.
Posted Sep 02, 2025 - 09:19 PDT
This incident affected: Site.