Issues exporting data

Incident Report for BreezeChMS

Resolved

Our Engineering teams have resolved the issues affecting exporting and things are working as expected!
Posted Nov 12, 2025 - 11:44 PST

Update

Our Engineering teams have pinpointed the cause of this issue and are working on a fix.
Posted Nov 12, 2025 - 11:33 PST

Investigating

Our teams are aware of an issue affecting the exporting Directory and Tax Statements. We will provide updates shortly.
Posted Nov 12, 2025 - 11:01 PST
This incident affected: Site and Database.